SPH IPv6 prefix delegation für OPNsense

      SPH IPv6 prefix delegation für OPNsense

      Hallo zusammen,

      ich betreibe seit gut 6 Monaten einen modifizierten SPH mit nachgelagerter Fritzbox. Es ist nun die Zeit gekommen endlich auf eine flexiblere Lösung umzusteigen. Dazu habe ich etwas Geld in die Hand genommen um einen OPNsense Router aufzusetzen. Ich habe nun allerdings ein Problem was ich mir nicht erklären kann (wahrscheinlich übersehe ich eine Kleinigkeit). Ich hatte in der Vergangenheit den SPH angepasst, damit er ein 60er Prefix liefert und die Fritzbox so konfiguriert (60er Prefix angefordert) das dieses auch zur Verfügung steht. Die Fritte gibt dann ein 64er Netz ins lokale LAN und ein Weiteres für Gast-LAN. Soweit so gut.
      Wenn ich jetzt OPNsense statt der Fritzbox nutze und ebenfalls ein 60er Prefix anfrage (LAN Interface steht auf Track IPv6 Interface, Prefix-ID 0) bekomme ich im LAN kein 64er Netz. Hat zufällig jemand solch ein Konstrukt im Einsatz und könnte mir eventuell einen Hinweis geben worauf ich noch achten muss?

      Ich habe zu Beginn einige Test an einem Privaten VDSL Anschluss hinter einer Fritzbox 7590 gemacht. Dort konnte ich problemlos mehrer Subnetze aufspannen (Prefix-ID 0,1,2...)

      Grüße
      Markus
      Hallo zusammen,

      ich konnte zwischenzeitlich mein Problem lösen. Es war natürlich wieder mal eine Kleinigkeit. Damit sich der 'Nächste' keinen absucht, hier mal die Settings.

      Im WAN Interface habe ich folgendes gesetzt:

      IPv6 Configuration Type -> DHCPv6
      Configuration Mode -> BASIC
      Request only an IPv6 prefix -> X
      Prefix delegation size -> (In meinem Fall) 60
      Send IPv6 prefix hint -> X
      Directly send SOLICIT -> X
      Prevent release -> X

      Bis zu diesem Punkt war auch alles klar, jetzt aber dass Wichtigste:
      Meine frische OPNsense Installation hatte keinen 'DHCP Unique Identifier' gesetzt. Prüft dies also bitte unter

      Interfaces -> Settings -> DHCP Unique Identifier

      Falls nichts eingetragen ist, mit 'Insert a new LLT DUID' neuen Identifier generieren und speichern.
      Zur Sicherheit hatte ich einen Neustart gemacht, sollte aber auch ohne funktionieren.

      Danach hat es dann einwandfrei geklappt mit der Prefix-Vergabe auf allen VLANs.

      Grüße
      Markus