Angepinnt Telnet aktivieren

      @danXde

      bisher komme ich auf max. 3 Balken (konstant) mit externer Antenne.
      DL max 53.000 UL 13.000 - immerhin ein riesen Gewinn im Vergleich zu vorher.
      Leider bin ich von Gebäuden/Bäumen umzingelt und der 1800MHz Mast steht in gut 10km Entfernung.
      Dazu ist die externe Antenne ein 15 Euro Ebay Kauf ;)
      Fürs erste bin ich sehr zufrieden.
      Eine richtig gute Antenne mit entsprechenden Kabeln kommt auf ca. 230 Euro - bin skeptisch ob sich diese Investition lohnt.

      Beste Grüße,
      MastaB

      Nachtrag:
      RSRP von -111 auf -96
      RSRQ von -11 auf -10
      Moin,

      Telnet aktiviert sich bei mir irgendwie nicht. :/

      Firmware: 050124.04.00.005

      PS: Habe die Bash-Version (Linux) zum de-/encrypten genommen.

      Habe die Config noch einmal vom SPH gesichert und erneut decrypted um zu schauen, ob Telnet tatsächlich aktiviert ist... und es steht beim Telnet definitiv eine 1, somit müsste es aktiviert sein.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „cleanlock“ ()

      danXde schrieb:

      @cleanlock in der Firmware ist kein Telnet mehr drin. Du kannst es in der Config zwar aktivieren, das nützt aber nur noch um danach von aussen auf das LTE-Modem zugreifen um die Frequenz fixieren zu können.

      Mit der Version musst Du den Hardwarebreak durchführen, oder auf einer kleiner V2.0.12 downgraden.

      Grüße

      danXde


      Hi, alles klar. Allerdings funktioniert das fixieren der Frequenz anscheinend nicht so ganz. Frequenz ist E1800MHz, also will ich sie auf 1800MHz locken/fixieren und drücke Speichern. Nachdem ich aber das Programm neu starte, ist die Auswahl in der Liste wieder leer, also scheint er die Fixierung nicht zu übernehmen.
      @danXde Gibt es denn eine Lösung wie man den SPH auf die 1800MHz fixiert, ist vielleicht SSH/Dropbear möglich, wenn Telnet schon nicht mehr funktioniert und kann denn nicht einfach über die entschlüsste/bearbeitete Konfig-Datei eine oder mehrere statische routen eingetragen werden um auch das "SPH-LAN" intelligent zu machen (ich nehme mal an, dass die meisten den DHCP des SPH nutzen wollen aufgrund des hartnäckigen IPV6-Thema, hier lässt sich der DHCPv6 nämlich leider nicht so einfach deaktivieren und IPv6 wird doch soweit ich weiß für den Tunnelaufbau gebraucht, kann daher nicht ganz abgeschaltet werden).

      Übirgens bei meiner Entschlüsselung gab es eine Fehlermeldung:

      Quellcode

      1. /tmp$ sh spcrypt.sh -e Speedport_Hybrid_050124.03.07.001_15.02.2019_151615.config test.config
      2. spcrypt.sh: 11: [: ==: unexpected operator
      3. spcrypt.sh: 22: [: 1: unexpected operator


      Der Code ist trotzdem lesbar und ich kann editieren. Ist das bedenklich oder kann ich nach der Änderung mit gutem Gewissen wieder encodieren und die Config-Datei zurückspielen?
      @suppenkasper ...ja, man kann weiterhin den Router fest auf eine Frequenz (oder paarweise ausgewählte Frequenzen) fixieren. Config entschlüsseln, telnet aktivieren und dann die config wieder verschlüsseln und einspielen. Wenn's beim Einspielen Probleme gibt, dann müsste man sich den Fehler mal anschauen, oder mit einer anderen Methode decodieren. SSH kann man nur noch über den Hardwarebreak nachrüsten, weil man ja nicht mehr per Softbreak mit telnet reinkommt. Routen konnte man bis zum nächsten Reboot im Hiddenmenü nachrüsten, das bringt blos nix, da das NAT diese nicht unterstützt und somit diese Netze keinen Internetzugriff bekommen.

      Einmal drin im Router, stehen einem sämtliche Möglichkeiten offen. Ich möchte das jetzige Featureset meines getunnten SPH nicht mehr missen.

      Grüße

      danXde

      Nexusband schrieb:

      @danXde funktioniert das denn mit den neuen Firmwareversionen wieder? Als neuer Hybrid-User hat mein Speedport natürlich die neuste Firmware schon "ab Werk" drauf gehabt und ich würde gerne auf 1800 MHz festsetzen um mal zu schauen welcher der Masten hier überhaupt noch was liefert mit 1800 MHz...die 800 MHz sind eine Katastrophe...
      Für die reine Frequenzfixierung ist gar kein Telnet notwendig - das Flag zu setzen reicht schon, damit man das LTE-Modul im LAN erreichen kann. (das Flag kann zwar in den neueren Firmwares kein Telnet mehr aktivieren, senkt aber die 'innere' Firewall)
      -- danach kann man mit 'SpeedportHybridControl' oder per Kommandozeile/AT-Kommando die Frequenz setzen.

      mfg, emkay

      EDIT: Sorry, war danXdes Link nich gefolgt - er hat Dir ja die Kurzanleitung schon verlinkt... :D
      Hi,

      gibt es etwas bekanntes was den Telnet Zugriff trotz geänderter Config verhindert? Ich habe meine Config gerade noch mal entladen und entschlüsselt. Telnet ist dort noch aktivert. Trotzdem bekomme ich keinen Loginprompt bei Telnet <speedporthybridip>

      Ich hänge direkt mit LAN Kabel am Router. Der Router ist bereits fest auf 1800 MHz gepinnt, das funktioniert soweit alles. Das SPH Tool funktioniert auch ?(

      Gruß
      René
      Ich glaube ich habs schon rausgefunden. Telnet geht nicht aufgrund der zu neuen Firmware. Ich wollte eigentlich das Script testen welchen hier im Forum vorgestellt wurde um den Router immer wieder zu trennen bis er sich mit einer bestimmten Zelle verbunden hat. Das geht dann wohl nur durch ein Firmware Downgrade oder?